手机版
你好,游客 登录 注册
背景:
阅读新闻

Vim 和 NeoVim 曝出高危漏洞

[日期:2019-06-13] 来源:solidot.org  作者:Linux [字体: ]

Vim 和 NeoVim 曝出了一个允许任意代码执行的高危漏洞。漏洞编号 CVE-2019-12735,Vim 8.1.1365 和 Neovim 0.3.6 之前的版本都受到影响。漏洞位于编辑器的  modelines 功能中,该功能允许用户指定窗口大小和其它定制选项,modelines 限制了沙盒内可用的指令。

但安全研究员 Armin Razmjou 发现 source! 指令会绕过这一保护。因此如果用户打开一个恶意文本文件,攻击者可以控制计算机。

Vim 和 NeoVim 曝出高危漏洞

Vim 和 NeoVim 曝出高危漏洞 

漏洞利用需要编辑器启用 modelines,部分 Linux 发行版默认启用了该功能,而苹果的 macOS 没有默认启用。

Ubuntu 18.04上安装 Neovim以及安装使用配置  https://www.linuxidc.com/Linux/2019-01/156540.htm

Vim实现分屏操作  https://www.linuxidc.com/Linux/2019-03/157689.htm

Vim复制剪切粘贴设置行号等技巧 https://www.linuxidc.com/Linux/2019-01/156604.htm

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2019-06/159073.htm

linux
相关资讯       Vim漏洞  NeoVim漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款