手机版
你好,游客 登录 注册
背景:
阅读新闻

Debian GNU/Linux发布Linux内核安全更新,修复14个漏洞

[日期:2019-08-22] 来源:Linux公社  作者:醉落红尘 [字体: ]

Debian项目为其稳定的受支持发行版发布了一个新的Linux内核安全更新,以解决可能使用户计算机面临风险的多个漏洞。

新的Linux内核安全更新适用于Debian GNU/Linux 10 “Buster”和Debian GNU/Linux 9 “Stretch”操作系统系列,可解决各种安全研究人员发现的14个漏洞。 Debian项目敦促所有用户尽快更新其安装。

在修补的安全漏洞中,我们可以提到支持串行连接SCSI(SAS)设备的libsas子系统中的竞争条件,块子系统中潜在的双重免费,以及两个可以使攻击者更容易利用的问题其他漏洞。

此外,安全补丁解决了Linux内核的vfio实现,vhost驱动程序,IPv4多播路由实现,没有Transactional Memory(TM)的PowerPC(ppc64el)系统以及UART连接的蓝牙适配器所需的各种驱动程序中发现的问题。这可能会导致拒绝服务。

另外还修复了一个已有4年历史的漏洞,该漏洞尚未完全解决,这可能会导致运行Xen来宾时主机上出现拒绝服务(意外的NMI)。但是,研究人员指出,此问题的修复程序与2.5之前的QEMU版本不兼容。

 Debian 10.0 “Buster” 正式发布下载,由Linux 4.19, GNOME + W

用户必须立即更新他们的系统

新的Linux内核安全补丁还修复了在TCP套接字实现中发现的可能的释放后使用,这可能让本地用户升级他/她的权限或导致内存损坏或系统崩溃,以及gtco驱动程序中的错误用于USB输入平板电脑,允许具有恶意USB设备的物理存在用户升级他/她的权限或导致拒绝服务。

虽然软盘现在已经灭绝,但有两个问题会影响Linux内核的软盘驱动程序,一个潜在的零分区缺陷和缺少边界检查错误,这两个漏洞都允许本地攻击者访问软盘而导致拒绝从I/O缓冲区之外的内核内存中获取或获取敏感信息。

还发现IP分组ID的生成使用弱散列函数,这可以在各个计算机与来自不同网络的各种远程服务器通信时跟踪它们。要解决此问题,现在使用“siphash”哈希函数而不是“jhash”。

最后但并非最不重要的是,新的Debian Linux内核补丁减轻了影响大多数x86处理器的众所周知的Spectre variant 1安全漏洞的子类型,当从用户模式访问内核时,这显然可以跳过条件SWAPGS指令。虽然i386内核不受影响,但通过使用内存屏障来限制推测性执行来修复该问题。

“据发现,大多数x86处理器可以推测性地跳过从用户模式进入内核时使用的条件SWAPGS指令,和/或可以在跳过它时推测性地执行它。这是Spectre variant 1的子类型,它可以允许本地用户从内核或其他进程获取敏感信息,“阅读安全公告

所有这些安全漏洞现在都在最新的稳定的Debian GNU/Linux 10 “Buster”操作系统系列以及旧的稳定的Debian GNU/Linux 9 “Stretch”操作系统系列中进行了修补。 Debian GNU/Linux 10 “Buster”的用户应安装内核版本4.19.37-5+deb10u2,而Debian GNU/Linux 9 “Stretch”用户必须安装内核版本4.9.168-1+deb9u5。

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2019-08/160268.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款