手机版
你好,游客 登录 注册
背景:
阅读新闻

Apache NiFi 身份验证安全漏洞 (CVE-2019-12421)

[日期:2019-11-22] 来源:Linux社区  作者:Linux [字体: ]
Apache NiFi 身份验证安全漏洞 (CVE-2019-12421)


发布日期:2019-11-18
更新日期:2019-11-22

受影响系统:

Apache Group NiFi 1.0.0 - 1.9.2

描述:


CVE(CAN) ID: CVE-2019-12421

Apache NiFi是Apache Software Foundation的一个软件项目,旨在自动化软件系统之间的数据流。该系统主要用于数据路由、转换和系统中介逻辑。

Apache NiFi 1.0.0版本至1.9.2版本,在身份验证机制中存在安全漏洞,该漏洞源于在用户注销后,NiFi将客户端的身份验证令牌失效,而非使服务器端的令牌失效。攻击者可利用该漏洞向NiFi发送API请求。

<*来源:Abdu Sahin
  *>

建议:


厂商补丁:

Apache Group
------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://nifi.apache.org/security.html#CVE-2019-12421

linux
相关资讯       Apache NiFi安全漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款