手机版
你好,游客 登录 注册
背景:
阅读新闻

Linux kernel qrtr_tun_write_iter()拒绝服务安全漏洞 (CVE-2019-19079)

[日期:2019-11-22] 来源:Linux社区  作者:Linux [字体: ]
Linux kernel qrtr_tun_write_iter()拒绝服务安全漏洞 (CVE-2019-19079)


发布日期:2019-11-18
更新日期:2019-11-22

受影响系统:

Linux kernel < 5.3

描述:


CVE(CAN) ID: CVE-2019-19079

Linux kernel是开源操作系统Linux所使用的内核。

Linux kernel 5.3之前版本,net/qrtr/tun.c中的qrtr_tun_write_iter()函数存在内存泄露漏洞。可导致拒绝服务(内存耗尽)。

<*来源:vendor
  *>

建议:


厂商补丁:

Linux
-----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3
https://github.com/torvalds/linux/commit/a21b7f0cff1906a93a0130b74713b15a0b36481d

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款