手机版
你好,游客 登录 注册
背景:
阅读新闻

Harbor 特权提升安全漏洞 (CVE-2019-19023)

[日期:2019-12-06] 来源:Linux公社  作者:醉落红尘 [字体: ]
Harbor 特权提升安全漏洞 (CVE-2019-19023)


发布日期:2019-12-03
更新日期:2019-12-06

受影响系统:

Harbor Harbor 1.9.*
Harbor Harbor 1.8.*
Harbor Harbor 1.7.*

不受影响系统:

Harbor Harbor 1.9.3
Harbor Harbor 1.8.6

描述:


CVE(CAN) ID: CVE-2019-19023

Harbor是一个开源镜像管理项目,通过添加一些用户常用的功能特性,例如安全、标识和管理等,扩展了开源Docker Distribution。

Harbor 在实现中存在特权提升漏洞,该漏洞使普通用户可以通过API调用来修改特定用户的电子邮件地址,从而获得管理员帐户特权。漏洞源于Harbor API没有对修改电子邮件地址的API请求进行适当的权限限制。

<*来源:Anonymous
 
  *>

建议:


厂商补丁:

Harbor
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/goharbor/harbor/security/advisories/GHSA-gcqm-v682-ccw6

https://github.com/goharbor/harbor/security/advisories/GHSA-3868-7c5x-4827

https://github.com/goharbor/harbor/security/advisories/GHSA-qcfv-8v29-469w

https://github.com/goharbor/harbor/security/advisories/GHSA-rh89-vvrg-fg64

https://github.com/goharbor/harbor/security/advisories/GHSA-6qj9-33j4-rvhg

下载链接:

https://github.com/goharbor/harbor/releases

linux
相关资讯       Harbor  Harbor漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款