手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

CVE-2020-7471:Django SQL注入漏洞警报

[日期:2020-02-14] 来源:Linux公社  作者:醉落红尘 [字体: ]

最近,Django正式发布了一条安全公告,该公告宣布了一个潜在的SQL注入漏洞(CVE-2020-7471),该漏洞已通过StringAgg(分隔符)加以利用。

攻击者可以将构造函数分隔符传递给django.contrib.postgres.aggregates.StringAgg聚合函数,以绕过转义并注入恶意SQL语句。

Ubuntu 18.04 LTS 上安装 Django 图文详解

受影响的版本

  • Django master branch
  • Django 3.0
  • Django 2.2
  • Django 1.11

解决方案

Django正式发布了一个新版本来修复上述漏洞。 受影响的用户会尽快更新到Django的master分支以及3.0、2.2和1.11版本分支

如果使用pip安装Django,则可以使用以下命令进行操作:

[root@localhost /home/linuxidc/www.linuxidc.com]$ pip install -U Django

 

Ubuntu 18.04 LTS 上安装 Django 图文详解  https://www.linuxidc.com/Linux/2019-12/161673.htm

 

Django 3.0 发布,内置异步功能并支持MariaDB和Python 3.6、3.7和3.8  https://www.linuxidc.com/Linux/2019-12/161672.htm

 

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2020-02/162302.htm

linux
相关资讯       Django漏洞  CVE-2020-7471 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款