手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

Debian安全更新时缺少验证公钥的问题

[日期:2014-11-03] 来源:Linux社区  作者:yygydjkthh [字体: ]

/*********************************************************************
 * Author  : Samson
 * Date    : 11/02/2014
 * Test platform:
 *              3.13.0-24-generic
 *              GNU bash, 4.3.11(1)-release
 * *******************************************************************/

添加Debian的安全更新到系统的更新源配置文件中:

v0id@v0id /etc/apt/sources.list.d $ sudo vim official-package-repositories.list

deb http://security.debian.org/ wheezy/updates main contrib non-free

使用apt-get进行源的更新:

v0id@v0id /etc/apt/sources.list.d $ sudo apt-get update

结果在更新的过程中出错了,出错信息如下:

正在读取软件包列表... 完成

W: GPG 错误:http://security.debian.org wheezy/updates InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 8B48AD6246925553

造成以上的错误问题的原因是因为没有签名公共密钥造成的,这里就要使用密钥管理工具进行下载缺少的公钥了:

注意,下面的最后的一串连续的编号即为上面报错中缺少的公钥的编号;

v0id@v0id $ sudo apt-key adv --recv-keys --keyserver keyserver.Ubuntu.com 8B48AD6246925553

然后,再使用apt-get update就没有问题了。

本文永久更新链接地址http://www.linuxidc.com/Linux/2014-11/108918.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款