你好,游客 登录 注册 搜索
背景:
阅读新闻

Quagga 缓冲区溢出漏洞(CVE-2016-1245)

[日期:2017-03-22] 来源:Linux社区  作者:Linux [字体: ]
Quagga 缓冲区溢出漏洞(CVE-2016-1245)


发布日期:2016-10-18
更新日期:2017-03-22

受影响系统:

Quagga Quagga < 1.0.20161017

描述:


BUGTRAQ  ID: 93775
CVE(CAN) ID: CVE-2016-1245

Quagga是管理IPv4及IPv6等路由协议的软件。

Quagga < 1.0.20161017版本,zebra程序处理IPv6邻居发现消息时存在栈缓冲区溢出漏洞。此漏洞源于BUFSIZ兼容消息大小。

<*来源:David Lamparter
  *>

建议:


厂商补丁:

Quagga
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.gossamer-threads.com/lists/quagga/users/31952
https://bugzilla.redhat.com/show_bug.cgi?id=1386109
https://github.com/Quagga/quagga/commit/cfb1fae25f8c092e0d17073eaf7bd428ce1cd546
https://www.debian.org/security/2016/dsa-3695

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-03/142066.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款