手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

Python 3 使用PyMySQL连接Inception 问题

[日期:2018-01-28] 来源:Linux社区  作者:amnesiasun [字体: ]

PyMySQL 连接Inception ,在判断版本时会出现value error 问题。原因是pymysql通过‘.’进行分割,但是Inception的版本信息是这样的

./mysql -V

 Ver 14.14 Distrib Inception2.1.50, for Linux (x86_64) using  EditLine wrapper

Oracle mysql的版本是:

mysql  Ver 14.14 Distrib 5.7.18, for Linux (x86_64) using  EditLine wrapper

因此Pymysql获取到的值为Inception2,最后int() 报value error。

可以简单修改pymysql connections.py(只是解决了问题,对具体代码还不是很了解)

    def _request_authentication(self):
        # https://dev.mysql.com/doc/internals/en/connection-phase-packets.html#packet-Protocol::HandshakeResponse
        if self.server_version.split('.', 1)[0] == 'Inception2':
            self.client_flag |= CLIENT.MULTI_RESULTS
        elif int(self.server_version.split('.', 1)[0]) >= 5:
            self.client_flag |= CLIENT.MULTI_RESULTS

使用Pymysql connection配置可以是下面这样

 conn = pymysql.connect(host='127.0.0.1',
              user='',
              passwd='',
              db='',
              port=6669,
              autocommit=True,
              cursorclass=pymysql.cursors.DictCursor,
              charset='utf8mb4'
              )

本文永久更新链接地址http://www.linuxidc.com/Linux/2018-01/150616.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款