手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

ImageMagick 拒绝服务安全漏洞( CVE-2018-16644)

[日期:2018-09-11] 来源:Linux社区  作者:Linux [字体: ]
ImageMagick 拒绝服务安全漏洞( CVE-2018-16644)


发布日期:2018-09-06
更新日期:2018-09-11

受影响系统:

ImageMagick ImageMagick 7.0.8-11

描述:


CVE(CAN) ID: CVE-2018-16644

ImageMagick是一套开源的图象处理软件。该软件可读取、转换、写入多种格式的图片。

ImageMagick 7.0.8-11版本,coders/dcm.c文件的和coders/pict.c文件存在安全漏洞,该漏洞源于在‘ReadDCMImage’函数和‘ReadPICTImage’函数中程序没有检测长度。远程攻击者可借助特制的图像文件利用该漏洞造成拒绝服务。

<*来源:vendor
  *>

建议:


厂商补丁:

ImageMagick
-----------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://github.com/ImageMagick/ImageMagick/issues/1269

Linux公社的RSS地址:https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2018-09/154012.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款