手机版
你好,游客 登录 注册
背景:
阅读新闻

Canonical为Ubuntu发布重要的Linux内核安全补丁,解决20多个安全漏洞

[日期:2019-04-03] 来源:Linux公社  作者:醉落红尘 [字体: ]

Canonical为所有受支持的Ubuntu Linux操作系统发布了一个重要的Linux内核安全补丁,以解决最近在上游内核中发现的二十多个漏洞。

适用于Ubuntu 18.10(Cosmic Cuttlefish),Ubuntu 18.04 LTS(Bionic Beaver),Ubuntu 16.04 LTS(Xenial Xerus),Ubuntu 14.04 LTS(Trusty Tahr),以及Kubuntu,Xubuntu,Lubuntu等所有官方衍生产品。 ,新的Linux内核安全补丁可以解决影响Linux 4.18,Linux 4.15,Linux 4.4和Linux 3.13内核系列的20多个安全漏洞。

在已修复的问题中,我们可以提到Linux内核的ALSA(高级Linux声音架构)子系统中的use-after-free漏洞,该漏洞可能允许物理上接近的攻击者使系统崩溃,以及在蓝牙实施中发现的信息泄漏,这可能让蓝牙范围内的攻击者暴露敏感信息。

安全补丁还解决了在使用嵌套虚拟化时在Linux内核的KVM(基于内核的虚拟机)子系统中发现的信息泄漏漏洞,这可能让攻击者将敏感信息从主机系统暴露给来宾虚拟机,以及其他几个KVM漏洞影响客机。

此主要安全更新中修补的其他漏洞包括在Linux内核的用户空间API中发现的用于加密(af_alg),IPMI,基于L2TP的PPP和SCTP实现以及NFS41+子系统中的use-after-free漏洞F2FS文件系统实现中的条件,以及eBPF,SNMP NAT,CAN,mmap和Btrfs文件系统实现中的错误以及USB串行设备驱动程序。

 

敦促用户立即更新他们的系统

建议用户立即将其系统更新为各自的Ubuntu版本和体系结构的新内核版本。现已在官方Ubuntu存储库中提供补丁内核,用于32位和64位系统,Raspberry Pi 2设备,云环境,OEM处理器,Snapdragon处理器,以及Amazon Web Services(AWS),Google Cloud Platform(GCP) ,Microsoft Azure云和Oracle云系统。

HWE(硬件启用)内核也可用于使用Ubuntu 18.10的Linux 4.18内核的Ubuntu 18.04.2 LTS系统,使用Ubuntu 18.04 LTS的Linux 4.15内核的Ubuntu 16.04.6 LTS系统,使用Ubuntu 16.04 LTS的Linux 4.4内核的Ubuntu 14.04.6 LTS系统,和Ubuntu 12.04 ESM系统使用Ubuntu 14.04 LTS的Linux 3.13内核。 在应用新内核版本后,请记住重新启动系统。

更多Ubuntu相关信息见Ubuntu 专题页面 https://www.linuxidc.com/topicnews.aspx?tid=2

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2019-04/157927.htm 

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款