手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

Flatpak 1.7 进入开发,将带来新功能和改进

[日期:2020-04-01] 来源:Linux公社  作者:醉落红尘 [字体: ]

Flatpak的维护者Alexander Larsson今天宣布了一个新的不稳定版本系列,那就是针对基于Linux的操作系统Flatpak 1.7。

Flatpak 1.7系列首次进行重大更改,即简化了对OSTree P2P(点对点)支持的安装。

因此,Flatpak 1.7和更高版本将不再支持从本地网络对等方安装应用程序。此外,从本地USB设备的加载将不再是自动的,用户必须通过配置加载存储库来启用该功能。

Flatpak 1.7 进入开发,将带来新功能和改进

Alexander Larsson表示,可以通过从/var/lib/flatpak/sideload-repos或 /run/flatpak/sideload-repos符号链接到侧载存储库来创建侧载存储库,他承诺由于此更改,P2P支持将更加有效。

Flatpak 1.7不稳定系列中的第一个版本还引入了新的“ host-etc”和“ host-os”文件系统权限,以授予对系统/usr和/etc的访问权限。

此外,它在配置中使libsystemd成为可选选项,引入日记套接字的只读安装,并且如果Flatpak应用程序具有文件系统访问权限,则可以使主机 host /lib目录作为/run/host/lib访问。

在底层,Flatpak代码已得到简化,现在它使用variant-schema-compiler生成更有效的代码,用于从OSTree(用于对基于Linux的操作系统进行版本更新的系统)中解析GVariant文件。

最后但并非最不重要的一点是,文档导出组件获得了对导出目录的支持,这需要新的门户网站版本,并且DConf迁移功能现在支持对象路径中的版本号。

Flatpak 1.7.1可以从项目的GitHub页面下载,但不建议用于生产环境。 Flatpak 1.7不稳定系列很可能会作为1.8稳定版本发布。

同时,Flatpak 1.6.3稳定版本今天也发布,其中包含使用额外数据的应用程序Bubblewrap 0.4.1的应用程序的进度计算中的回归修复程序,该修复程序用于在未配置任何遥控器的情况下发生的“ flatpak修复”崩溃问题,更新的OCI身份验证器和更新的翻译。

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2020-04/162779.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款