手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

赶快打补丁,Exim使40万服务器可能面临严重的代码执行漏洞

[日期:2018-03-08] 来源:Linux公社  作者:醉落红尘 [字体: ]

一个不知名但被广泛使用的电子邮件程序Exim的漏洞可能会使全世界多达40万的服务器面临严重攻击的风险,直到他们安装更新。

Exim是可用于Ubuntu的电子邮件MTA服务之一,而Exim4是Debian的默认设置。 Exim代表实验性Internet Mailer,于1995年在英国剑桥大学为Unix系统开发,作为Sendmail的替代品。

发现漏洞的研究人员在周二发布的一份报告中警告说,这个漏洞除了版本4.90.1 外,这一缺陷在所有版本中都可以执行恶意代码。缓冲区溢出漏洞被索引为CVE-2018-6789,位于base64解码函数中。通过向运行Exim的服务器发送特殊操作的输入,攻击者可能能够远程执行代码。

Devcore安全咨询公司的研究人员称, “利用漏洞产生的单字节数据,在字符串适合某个特定长度时会覆盖一些关键数据”。另外,这个字节是可控制的,这使得开发更加可行。Base64解码是一个基本功能,因此这个bug很容易触发,导致远程代码执行。”

就Exim而言,Exim的开发人员在一份报告中写道:“如果满足一些前提条件,base64d()中会有缓冲区溢出。使用手工消息,远程代码执行似乎是可能的。目前,我们不确定漏洞的严重程度。 相信漏洞利用非常困难,缓解措施不得而知。”

Devcore的研究人员表示多达40万台服务器处于危险之中。 Shodan计算机搜索引擎上的查询发现了大量报告运行中存在漏洞的版本的服务器。开发人员在2月10日发布了版本为4.90.1的修复程序。任何使用Exim的组织都应确保其使用的是最新版本。

本文永久更新链接地址https://www.linuxidc.com/Linux/2018-03/151249.htm

linux
相关资讯       Exim  Exim代码执行漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款